MCSF P0601 error 2.4 20v jtd - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 1 Old 19-02-13 Thread Starter
Status: -
AO Member
Join Date: Oct 2011
Location: I would rather not say
County: -
Posts: 117

Member car:


MCSF P0601 error 2.4 20v jtd

After sorting out my problem of the infocenter being dead, and have also diagnosed a 1v difference between the engine and the battery (which explains the poor battery charging voltage) I am trying to sort out the MCSF error which appears to be caused by a P0601 Checksum error.

The car has been remapped by Perfect Touch by the previous owner, and I'm wondering if the infocenter was purposely unplugged due to a bad remap... The car itself pulls like a train, all be it rather smokey, but thats down to a duff MAF sensor by the looks of it anyways (which I've ordered today). It doesn't appear to go into limp home mode.

I've ordered a new MAF today, and also an earth strap, I'm just stuck with this MCSF fault at the moment that I'd ideally like to clear.

MoleUK is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

20v , error , jtd , mcsf , p0601

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome