156 Power Steering Question - Alfa Romeo Forum
You are currently unregistered, register for more features.    
 
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 18-02-13 Thread Starter
Status: Confused by Selespeeds!
AO Member
 
Join Date: Sep 2011
Location: United Kingdom
County: Merseyside
Posts: 29

Member car:

156

156 Power Steering Question

When topping up my power steering fluid this morning I found a cylindrical filter (approx. 2in long) bobbing in the fluid. I guess it's supposed to be fixed somewhere but have no idea whereabouts! I searched round the reservoir with my fingers but there's no obvious place for it. Can someone suggest how I can refit this or point me in the direction of a diagram for 156 JTS (02 plate) Selespeed's Power Steering reservoir?

Thanks

Last edited by WildStar; 18-02-13 at 14:02.
WildStar is offline  
Sponsored Links
Advertisement
 
Status: -
AO Member
 
Join Date: Nov 2012
Location: United Kingdom
County: -
Posts: 167
I am stick my neck out here a bit......the filter is from inside the fluid reservoir, and acts to filter the fluid as its drawn into the system and circulated.

Now I've had many cars over the years and this is the first time I've ever seen such an arrangement on power steering systems. After much puzzling recently about why my pump was making such screams and wails, as well as blowing air through the pipes and blowing the fluid out of the top of the reservoir (making a real mess), it was clear that there was a blockage, causing the pump to run dry and draw in air, and it seemed to me that the filter was the problem. Attempts to clean were unsuccessful though it looked fine. So I took it out.

Result? Blissful silence and no more chucking out the fluid. I'm happy that the world isnt going to stop revolving on its axis - the fluid was flushed through several times and is fresh, so regular changes will negate the need for super-fine filtration. And every other car does without one...
Ohdear is offline  
Reply

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

Tags
156 , power , question , steering

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome