Suspension squeak - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 7 Old 17-02-13 Thread Starter
Status: -
AO Member
nkbish0p's Avatar
Join Date: Sep 2012
Location: United Kingdom
County: Nottinghamshire
Posts: 46
Suspension squeak

Sorry for the lack of technical knowledge...

Had my 147 just under 3 months and I've put around 5000 miles on it. In the last week or so the (left front wheel) suspension has began making a (fairly loud) squeaking noise whenever hit an uneven bit of road. Any ideas what this is/whether it is serious enough to get checked out before I get my car serviced in the summer?

nkbish0p is offline  
Sponsored Links
Status: The Rosso twins are here!
Club Member
Membro Premio
edraven71's Avatar
Club Member Number: 1612
Join Date: Oct 2011
Location: United Kingdom
County: Tyne and Wear
Posts: 3,658
Squeak would usually be upper wishbone, search around loads of info on them.
edraven71 is offline  
Status: loving my ALFA
AO Member
Join Date: Nov 2011
Location: United Kingdom
County: Tyne and Wear
Posts: 860

Member car:

alfa gt jtdm

could be roll bar bushes
300stu is offline  
Status: busy
AO Silver Member
AutolussoSouth's Avatar
Join Date: Dec 2009
Location: United Kingdom
County: Dorset
Posts: 1,093
Will more than likely be the upper wishbone. Worn roll bar bushes tend to cause knocking over uneven surfaces rather than a creak / squeak.

AutolussoSouth is offline  
Status: -
AO Member
Join Date: Jul 2011
Location: Macedonia, The Former Yug
County: -
Posts: 562
With all respect, but it can be the ARB bushes. That what i found out after i changed the upper If it is the ARB bushes it can easily be checked, Alfa in the air, unbolt droplinks, tie rod end so ARB can be loose, move with your hand and maybe you`ll hear the lovely sound.
Toso is offline  
Status: Still love it
AO Member
Peter Simo's Avatar
Join Date: Aug 2012
Location: United Kingdom
County: Merseyside
Posts: 258
Images: 32
Recently had my upper wishbones replaced ,couldn't put up with the noise any longer ,like it was when I bought it now.
Peter Simo is offline  
Status: I have a GTA now!
AO Member
Alfa156Melb's Avatar
Join Date: Oct 2011
Location: Australia
County: Victoria
Posts: 930
Images: 14
Was the arb bushes for me. I replaced the uppers thinking that they were the culprit, creak still there.

So i disconnected the droplinks, tied the arb in place and went for a drive, noise gone.

Replaced the arb and now its perfect.

Since then, i replaced the lowers and dampers. Car is as new now
Alfa156Melb is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

squeak , suspension

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome