Strange ticking at 2k rpm - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 15-02-13 Thread Starter
Status: -
AO Member
Join Date: Jul 2009
Location: United Kingdom
County: South Yorkshire
Posts: 13

Member car:


Strange ticking at 2k rpm

I'm getting a strange ticking noise when at 2k rpm and it seems to be more noticeable when in gear. Also seems to be louder when de-accelerating. It sounds fine before and after 2k rpm.

It sounds a bit like some thing hitting a spinning fan.

Car is a 147 1.6ts Y reg.

Not affecting performance/mpg etc but its been getting more noticeable over the past few months. Any ideas?
pslack104 is offline  
Sponsored Links
Status: -
AO Silver Member
amfalconer's Avatar
Join Date: Aug 2011
Location: United Kingdom
County: Hampshire
Posts: 1,351
Images: 10

Member car:

147 1.6TS

First think I'd check is your exhaust manifold heatshield, if it's cracked, then sometimes it ticks
amfalconer is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

rpm , strange , ticking

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome