Blown BOSE - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 22-07-05 Thread Starter
Status: -
AO Member
Join Date: Mar 2003
Location: UK - West Yorkshire
Posts: 36

Member car:

147 -2.0

Blown BOSE

Evening all,
Just a quick post for advice really.

By the sounds of the NSF speaker, it seems that i have blown it.
I have an after market head unit, and very rarely play loud tunes, but the front speaker seems to have packed in after 2 years of the kenwood.

Anyone got any advice about swapping out the speaker?
the last time i swapped one on my 145 i bust the grill and never got the bloody thing back on.

And... should i swap like for like, or maybe put some components or uprated speakers in.?? (the bose has done the job up to press)

Any help would be greatly appreciated.

Mc_Fly is offline  
Sponsored Links
Status: -
AO Rosso Alfa Member
kurzon's Avatar
Join Date: Jul 2004
Location: London, UK
Posts: 45,472
Images: 1

Member car:

156 2.0 JTS

Re: Blown BOSE

Sorry to hear (no pun ) about you speaker problem. I think there have been a few threads here in the past on how to change speakers, so I would advise a search on that. Also, after reading up or advice here, check that something hasn't just fallen into the speaker area and is distorting the sound. Sorry can't help with your BOSE related upgrade speaker question etc, but if you don't mind can I ask you whether the Kenwood was setup to properly take advantage of your BOSE setup? By this, I guess I mean the equaliser settings, which I think some have mentioned before are disabled in the headunit if the car has BOSE BTW - I'm far from being an audio expert, so pardon my question if it turns out to be a silly one.

"I believe in coincidences. Coincidences happen every day. But I don't
trust coincidences." - Garak, DS9
So true
The BORED Collective
WE are SpartaBORED! I was DarthBORED! I am FearBORED! :elaugh: I was PredatorBORED! I was PhantomBORED!...of the AO-Theatre I have been iBORED! TerminatorBORED! He'll be back!
kurzon is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

blown , bose

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome