156 JTS Veloce - Engine Noise - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 05-02-13 Thread Starter
Status: -
Join Date: Jan 2013
Location: United Kingdom
County: West Midlands
Posts: 4
156 JTS Veloce - Engine Noise

Hi alfa addicts

My alfa 156 JTS Veloce (80k miles) (which i have owned for approx 3 weeks) has now started to sound like a diesel once it has warmed up.

I have done some snooping around on internet and it maybe the variator. Is this a common problem?? Easy to fix??

Engine oil level fine.

I'm going to do an engine oil and filter change - 10w60 appears to be the right grade - any offers on anything better to use??

Thanks for your help ....
FirstAlpha156 is offline  
Sponsored Links
Status: - Update
Posts: n/a
Very common I believe, if it is the variator then it's a cambelt removal and variator replacement to fix the noise problem... I also understand that although rather noisy it doesn't actually effect/damage the engine.... if yours is due a cambelt change get the variator done at the same time, I was recently quoted 116 for the variator and Avanti or the Alfa workshop will do it while they do the cam.

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

156 , engine , jts , noise , veloce

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome