Centre console and dials bulb issues - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 1 Old 04-02-13 Thread Starter
Status: Loving the Wizard exhaust!
AO Member
20v_gaz's Avatar
Join Date: Jan 2013
Location: United Kingdom
County: Warwickshire
Posts: 72
Images: 12
Hmmm Centre console and dials bulb issues

I have a facelift 156 2.4 JTD and have an ongoing issue that I feel needs sorting now as it's becoming irritating. Occasionally the tachometer, speedo, and centre console lights will all turn off (or flicker), and will only come back on if I give the top of the dash a thump. Obviously this is far from ideal but was wondering if anyone had any hints or tips as to what it could be and how best to fix it. I was thinking maybe a dry joint on the circuitry?

Also the temperature dial has a bulb out, so in true Italian spirit wonder if that could be part of the problem?

20v_gaz is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

bulb , centre , console , dials , issues

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome