156 rear window problem - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 26-01-13 Thread Starter
Status: -
Join Date: Jan 2013
Location: Australia
County: -
Posts: 7

Member car:

156 2.0 TS

156 rear window problem

Hey guys,

The rear windows in my 156 are playing up.

Using the switches from the drivers door, all windows work great. But when using the switches on either rear door, the windows either wind up or down a little bit at a time, or they don't.

Is this a common problem with these vehicles?

I'm assuming that it is simply a problem with the switch mechanism, as they feel very cheap.
DTentacle is offline  
Sponsored Links
Status: -
AO Platinum Member
David C's Avatar
Join Date: Aug 2003
Location: London, England
Posts: 28,993
That's a new one!

Be worth checking the isolator switch on the driver's panel too.
David C is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

156 , problem , rear , window

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome