147 Lusso Rear Window de-mister issue - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 4 Old 15-01-13 Thread Starter
Status: AO Member
AO Member
Join Date: Dec 2012
Location: United Kingdom
County: Lancashire
Posts: 20
147 Lusso Rear Window de-mister issue

Hi all I am looking for some info.
I have check other threads with de-mister issues but they do not cover what mine is doing.

The issue is it's not that it does not work at all, the very top element works great but none of the others do.

there not damaged at all no gaps etc, I have check the fuses an they all seem to be ok (will be replacing them at the weekend to be sure) but I would imagine there ok as the top element wouldn't work either if they were faulty.

It's got me total baffled......any ideas?
DarrenR is offline  
Sponsored Links
Status: Paint it black
AO Member
INS147's Avatar
Join Date: Oct 2010
Location: United Kingdom
County: Highlands
Posts: 551
Images: 4

Member car:


To be honest, it does sound a bit like the remainder of the element is knackered.
I think it's unlikely to be anything more complex than that, these things do keel over and die eventually
INS147 is offline  
Status: loving my ALFA
AO Member
Join Date: Nov 2011
Location: United Kingdom
County: Tyne and Wear
Posts: 860

Member car:

alfa gt jtdm

hi mate my Gt exactly same top half works bottom halfs knacked .Looked at ways of fixing it, only way to do so that looks accepable in my opinion is to replace the hatch or glass .You could get a hatch from a scrap yard
300stu is offline  
Status: -
AO Member
owlzen's Avatar
Join Date: Mar 2009
Location: United Kingdom
County: Wiltshire
Posts: 230

Member car:

Alfa 147 2.0 TS

You may be able to get the glass replaced under insurance windscreen cover. Mine was playing up a couple of years ago and one of the big windscreen companies agreed to replace it just for the cost of my windscreen excess. Might be worth asking the question.
owlzen is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

147 , demister , issue , lusso , rear , window

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome