147 1.9 JTD; idle cutting out - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 1 Old 14-01-13 Thread Starter
Status: -
Join Date: Aug 2010
Location: United Kingdom
County: Bedfordshire
Posts: 7

Member car:

147 1.9JTDM

147 1.9 JTD; idle cutting out

I'm sure I've read a similar thread previously but I cannot find it so I'm probably repeating this question: any ideas of what is causing the idle to occasional die on my 2005 JTD 147? Sometimes on a light throttle the engine hesitates momentarily but then continues. If clutch is depressed at this time engine will die. Awkward if I'm entering a roundabout at that moment and the power steering goes off. I remember reading some time back that it could be a dirty throttle body and I've also read that it could be a sticky EGR though the symptoms are different to what I had on my 159 which had no low end power. There is no warning light and the car otherwise runs like a train, great performance and economy. Please help!
ianden is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

147 , cutting , idle , jtd

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome