156 sunroof issue - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 1 Old 13-01-13 Thread Starter
Status: -
Join Date: Dec 2012
Location: United Kingdom
County: Cumbria
Posts: 3

Member car:

156 1.8TS

156 sunroof issue

Hi there,
My 156's sunroof seems to be well past its best.
The electric motor struggles to operate it, which I'm not overly concerned about.
The bigger problem is that the whole unit seems to have up and down movement. Strong side winds can force the panel to pop up, which on the motorway means an big increase in wind noise.
I've attempted to reset the position of the sunroof by loosening the 6 hex screws, setting the panel flush and tightening; but the whole assembly seems to be loose.

On top of all of this, the sunshade doesn't slide fore/aft particularly well, which seems to cause further foul-up of the sunroof slide operation.

As the sunroof seems to be a source for condensation caused by this 'loose fit', I could do with getting it sorted.
Can anyone suggest a fix for this?
dentyboy is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

156 , issue , sunroof

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome