QUESTION TIME #1 Jan 2013 LOL - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 4 Old 06-01-13 Thread Starter
Status: -
AO Member
The_Alfa_Male's Avatar
Join Date: May 2011
Location: United Kingdom
County: Greater London
Posts: 277
Images: 11

Member car:

Alfa romeo GT


1St of all happy new year team Alfa hope u had a fault and problem free Team Alfa Year.

Just a few quick lil concerns well questions really.

i have a Alfa GT 2.0 petrol, which i love but im starting to feel as if something may be alil off with it,

1st thing is it sounds like a diesel when its in idle, so not to sure y it is like that,

2nd thing is: im not to sure if its just me or becoz its cold but it seems like my exhaust seems 2 get seriously hot with in the 1st say 10mins of setting off, seems like alot steam comes out. maybe its 2 too then cools down or something i have no idea , i have seen other cars with this on coldish days so maybe im just being silly.

3rd lil problem is the passagener seat doesnt recline forward so ppl can get in the back, is this something i can fix myself or have to get done at a garage.

other than these things car is fine n well looked after , just want the car to look after me aka my pocket lool

let me no what u guys think

Go Team ALFA..!!!
The_Alfa_Male is offline  
Sponsored Links
Status: -
AO Member
Join Date: Feb 2008
Location: United Kingdom
County: West Lothian
Posts: 143

Member car:


1. Probably variator usually changed with timing belt
2. Sounds normal giving the current weather/temps
3. Can't help
MarkoGT is offline  
Status: Enjoying a nice mug of tea
AO Silver Member
Join Date: Oct 2008
Location: United Kingdom
County: Bedfordshire
Posts: 1,752
3. sounds like the release cable has given up - there are threads that descibe hoe to replace it.
CJO is offline  
Status: Powered by coal and steam
Club Member
Membro Premio
EVEL's Avatar
Club Member Number: 1382
Join Date: Jan 2007
Location: England
County: West Midlands
Posts: 9,808
Images: 7

Member car:

alph a ramayo

3. I have to give the top of the seat a little shove backwards as I'm pulling the lever to get mine to release
EVEL is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

2013 , jan , lol , question , time

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome