starting issue - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 4 Old 05-01-13 Thread Starter
Status: -
AO Member
Join Date: Jan 2013
Location: United Kingdom
County: Tyne and Wear
Posts: 39
starting issue


My car when starting takes a few cranks to turn over what could it be ?

1.9jtd GT 2006 with 116k

ITALIAN GT is offline  
Sponsored Links
Status: -
AO Silver Member
JakeC's Avatar
Join Date: Jan 2011
Location: United Kingdom
County: Staffordshire
Posts: 1,428

Member car:

Z4 3.0si

Battery I'd say, had the same problem myself recently.
JakeC is online now  
Status: -
AO Member
Willeh85's Avatar
Join Date: Jul 2012
Location: United Kingdom
County: Derbyshire
Posts: 26
Images: 10
I would be inclined to agree. I had similar symptoms about a month before Christmas, then went to use my car to go to work on Wednesday and nothing apart from the dimest flicker from the interior lights.

Swapped it for a new battery yesterday morning (from Eurocarparts currently got 15% off, and I picked it up) started instantly.

A friend has a battery charger/conditioner and he charged it overnight for me and said the white light indicator came on saying it needs topping up with whatever fluid it needs. (I don't know much about batteries)
Willeh85 is offline  
Status: The last of the 156 Interceptors...
AO Member
AutobotVanguard's Avatar
Join Date: Jun 2011
Location: United Kingdom
County: Cheshire
Posts: 982
Images: 348
I bought a cheap Bosch one here:

Cheap ALFA ROMEO 156 1.9 2005 Car Batteries - Free UK Delivery | Car Batteries Online

the 1.9 GT page seems to load petrol batteries so stick to this link or the 147 one instead.

AutobotVanguard is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

issue , starting

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome