jts running rich!! - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 4 Old 30-12-12 Thread Starter
Status: 156 1.8ts
AO Member
ROBBO156's Avatar
Join Date: Oct 2008
Location: United Kingdom
County: Gwynedd
Posts: 553
Images: 10
jts running rich!!

really strong smell when idling and high fuel consumption only just passed emish test on mot back in july. Cat??
ROBBO156 is offline  
Sponsored Links
Status: TJR Valeting
AO Silver Member
Tommywho156's Avatar
Join Date: May 2012
Location: United Kingdom
County: Leicestershire
Posts: 2,267
How's your thermostat?
If its jammed open and overcooling it will overfuel and its always worse in the winter.
Tommywho156 is offline  
Status: -
AO Silver Member
Join Date: Jul 2004
Location: United Kingdom
County: Derbyshire
Posts: 5,583
I had similar symptoms with my 145 when a temperature sensor failed - it was giving the ECU an incorrect low temperature reading. The temperature gauge still read the correct temperature as it used a different sensor.
Dave Brand is online now  
Status: -
AO Gold Member
Join Date: Aug 2007
Posts: 7,040
What year is your JTS?
Spider95 is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

jts , rich , running

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome