"Battery charge low" - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 06-12-12 Thread Starter
Status: -
AO Member
hopeisimportant's Avatar
Join Date: Aug 2008
Location: Aberdeen
Posts: 393
"Battery charge low"

I got a battery charge low warning tonight and all internal electrics went apart from some beeps.

This was after the car was sitting for about an hour tonight after a half hour drive. The dipped beam headlights also went off so I was just left with sidelights. I sat and let it idle for 5mins and the dash came back to life. I drove to halfords and got a free battery check which showed 100% charge and 75% start capacity so all seems good. My drive home was fine with no more warnings and I've put new bulbs in which has brought the headlights back to life.

Has anyone had a similar issue? I guess I will see what happens when I go to start it in the morning. Could the alternator be draining the battery when the engine is off?

Stand Free
hopeisimportant is offline  
Sponsored Links
Status: GTA facelift + engine rebuild. In progress
Club Member
Membro Premio
Joss's Avatar
Club Member Number: 1014
Join Date: Sep 2005
Location: United Kingdom
County: Dorset
Posts: 18,898
Images: 14
Probably get more response in the GTA section
Joss is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

battery charge low

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome