Helpppppppp - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 01-12-12 Thread Starter
Status: -
Join Date: Nov 2012
Location: United Kingdom
County: Kent
Posts: 7

Member car:



I have a 02 alfa 147 altanator packed up so had this replaced with a new one along with new battery. I can only get 11.8volts to charge back to the battery. My windows are really slow and go up inch by inch and my milage is constantly flashing. When alternator went it blew both headlight bulbs. I've had these replaced when other work was done but it's driving me mad now someone please help. It's getting to the point I wana scrap it love this car but it's really doing my head in now plz help anyone???,,
Mickalfakent is offline  
Sponsored Links
Status: Looking for Add ons
AO Member
Sharpshooter's Avatar
Join Date: Sep 2009
Location: United Kingdom
County: Kent
Posts: 578
Images: 5

Member car:

Alfa Romeo 147

Remove one of the terminals and measure the voltage across the battery. It may have fried it. Where in Kent are you?
Sharpshooter is offline  
Status: Sadly currently without an Alfa
AO Member
jonny rash's Avatar
Join Date: Dec 2011
Location: United Kingdom
County: Devon
Posts: 140
Maybe the alternator had not packed up at all. It could be a simple problem with the loom. for example, the exciter wire (or whatever it is the equivalent on an Alfa) may have a dodgy connector so it is not switching the alternator on.

Someone will be able to tell you which wire to jump direct to the battery to check this
jonny rash is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT


Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome