Help with Selepeed - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 29-11-12 Thread Starter
Status: -
AO Member
Join Date: Oct 2012
Location: Australia
County: New South Wales
Posts: 12

Member car:

2005 147

Help with Selepeed

I have a 147 selespeed and on several occasions lately the car has got stuck in third gear in manual mode and the gearbox will not neutralise until you turn it off. If you try to put in gear after starting it stays in neutral, I have left the car for up to half an hour but you can't hear the pump kick in when you open the door but if you leave it for 1hour when you open the door you hear the pump and when you start it everything is back to normal. I was wondering if anybody else has had similar problems and what the possible cause could be as I am only new to Alfa Romeo. Any help would be greatly appreciated.
morphbill is offline  
Sponsored Links
Status: Gold Member
AO Gold Member
rarebear's Avatar
Join Date: Sep 2002
Location: The Netherlands
Posts: 7,021
download multiecuscan and buy a 16 pin diagnose cable and ...diagnose...

see demo on youtube search for rarebear14
rarebear is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT


Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome