JTD idle when cold - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 28-11-12 Thread Starter
Status: waiting for summer
AO Member
Join Date: Mar 2006
Location: United Kingdom
County: North Yorkshire
Posts: 396
JTD idle when cold

Not really a problem (yet) would just like to know why.

From cold car starts no problem, it also idles nice and even just like it should. I then set of and reach fist junction a couple of hundred yards down road, and when you come to a stop the revs drop quite low, they then pick up to normal and are not a problem all day.

Anyone got any ideas what might cause the very low idle.
Maverick is offline  
Sponsored Links
Status: -
Join Date: Jan 2013
County: -
Posts: 1

Member car:

1.9 jtd 8v


I have the same problem with the engine idle speed. 1.9 JTD 8V
What was your problem? Can you help me?
katzen is offline  
Status: I ask a lot of questions!
AO Member
Join Date: Apr 2013
Location: United Kingdom
County: West Yorkshire
Posts: 439

Member car:

alfa gt 2.0 jts

isnt this normal?
piedthepiper is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

cold , idle , jtd

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome