Suspension issues - what else can it be??!! - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 4 Old 25-11-12 Thread Starter
Status: -
AO Member
Join Date: Sep 2011
Location: United Kingdom
County: Carmarthenshire
Posts: 84
Suspension issues - what else can it be??!!

Hi all, in addition to the problem with the lights on the dash of my 147 JTD 16v M-Jet (still working on those!), we have an issue with the near side front suspension..... it was making dreadful clonking noises on the uneven country roads we live on down here in south wales, so we have changed:

Lower suspension arms
Upper suspensions arms
Anti roll bar drop links
Top strut mounting (shock absorber mounting)

Whilst this has made a big difference, there is still a noise coming from the front near side when you go over a bump or dip in the road. It sounds like its coming from the top of the suspension, which is why we changed the top strut mounting, but it didn't make a difference

Does anyone have any suggestions as to what else it could be? The only thing we haven't changed is the anti roll bar rubbers, mainly because its a nightmare of a job and I cant see any play in them....... suggestions very welcome....thanks guys!!
Alfadevotee is offline  
Sponsored Links
AO Member
CraigMans's Avatar
Join Date: Sep 2007
Location: United Kingdom
County: West Yorkshire
Posts: 560
Are all the bolts tourqed up correctly? I had this sort of thing on my GTV. Turns out that one of the bolts on the bottom wishbone had blown its threads and it was only tight on three. Made a hell of a clunk over a speed bump.
CraigMans is offline  
(Post Link) post #3 of 4 Old 25-11-12 Thread Starter
Status: -
AO Member
Join Date: Sep 2011
Location: United Kingdom
County: Carmarthenshire
Posts: 84
Just checked all the bolts and they are fine.....just took it for a spin and noise seems to have disappeared - alfa's - you've got to love 'em!!!
Alfadevotee is offline  
Status: -
AO Silver Member
Join Date: Dec 2009
Location: United Kingdom
County: -
Posts: 1,171

Member car:

147 JTDM 16V

Could well be the ARB bushes. Disconnect the drop link on 1 side and see if you can easily move the bar side to side (in the direction along the bar). If you can then it's probably knocking. Doesn't seem to take much movement to make a load of noise. You may see no radial play in the bush, all it takes is a little sideways play.
Alexie is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

issues , suspension

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome