HELP!! Alfa 147 wiper problem. - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 24-11-12 Thread Starter
Status: -
Join Date: Nov 2012
Location: United Kingdom
County: Leicestershire
Posts: 1

Member car:

Alfa 147

HELP!! Alfa 147 wiper problem.

Hi there ... just bought my first ever Alfa, its a 147 twin spark, 1.6.

really happy with car, but it has a driver side wiper linkage problem. the plastic has broken off where it feeds into the crimped end of the metal bar.

does anybody know of a fix? or a good second hand supplier? Really dont want to pay the sort of figures Alfa are quoting. Im in Leicester, uK.

Kind regards,

englishdave is offline  
Sponsored Links
Status: -
AO Member
147cjl's Avatar
Join Date: Apr 2010
Location: United Kingdom
County: Falkirk
Posts: 226

Member car:

2002 147 1.6

Hi Dave, Autolusso do an exchange, your broken one for a fixed and reinforced one. I just got one from them and I'm happy with the results. Mine was exactly the same, the plastic end on the drivers side was snapped.
147cjl is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

147 , alfa , problem , wiper

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome