fuel gauge problems - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 22-11-12 Thread Starter
Status: ???
AO Member
alfaaddicted's Avatar
Join Date: Oct 2011
Location: United Kingdom
County: Lincolnshire
Posts: 237
Images: 62
fuel gauge problems

I have a 2004 156 1.9jtd and the fuel gauge is not working. What happens is when you turn the ignition on the gauge needle moves slightly and the orange light comes on then goes off then after 40 seconds (this time remains constant ) the gauge goes right over to the extreme full end of the scale. Then when you turn the ignition off the gauge stays full for another 15 seconds (again this does not change) and then goes off.
I have tried another fuel gauge off another car and that did not work ,I have looked for the wiring earthing out as much as i can but if it was a straight forward earthing problem the gauge needle would jump to full straight away without the delay wouldnt it?
By the way the fuel light appears to work when it should.
alfaaddicted is offline  
Sponsored Links
Status: Touring in my tourer
AO Member
Join Date: Jul 2012
Location: United Kingdom
County: Shropshire
Posts: 349
Sounds like the float is stuck at the top of the tank.
V6Hughes is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

fuel , gauge , problems

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome