2.0TS hunts and surges off the throttle? - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
Status: - Update
Posts: n/a
2.0TS hunts and surges off the throttle?

heres and odd one for the tech heads before i start ripping the engine bay to bits!

i have an 02 147 2.0l lusso, and recently it started to hunt and you can feel a small intermittent surging when your coasting towards a stop, in say 3rd gear, approaching an island or junction,

once the revs drop below about 2k, instead of a smooth deceleration, off the throttle, its as if some fuel leaks through intermittently when there should be none, creating a minor surge?

its not enough to accelerate forward, but enough that you feel that the engine braking has been interupted and no longer a smooth wind down.

on the throttle or hold it flat and steady, and its fine, and so far i have nothing to report from FES either,

so any pointers before the spanners come out?


Sponsored Links
Status: Tinkering
AO Member
Join Date: Nov 2012
Location: New Zealand
County: Wellington
Posts: 44
MAF? Otherwise does it idle correctly? If not I'd point finger at the idle controller as that can take control <2K RPM. Just the word "hunts" makes me think the latter is likely as that's symptomatic of faulty ISC\ICV units on most engines.

Last edited by stevelw; 15-11-12 at 22:51.
stevelw is offline  
Status: - Update
Posts: n/a
tick over/idle is steady as a rock,

perfect hot or cold, no rise and fall, no dropping upon arrival at standstill,

just when you're engine braking to a slow

i thought idle control valve myself, so reset the ecu for 24hours, and then allowed it to idle to reposition, all performed spot on 100% according to FES.

maybe i'll have to graph the maf parameters whilst the miss's drives a little, but does anyone know what the expected result for a good one should read "off" throttle?

i've only ever read target voltages for steadily increasing rpm, so not sure what the maf should read when engine is at speed but throttle closed?

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

20ts , hunts , surges , throttle

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome