Jts fuel issues - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 02-11-12 Thread Starter
Status: -
Join Date: Apr 2012
Location: United Kingdom
County: Cumbria
Posts: 7

Member car:

Alfa 156 2.0 JTS

Jts fuel issues

Hello All, My 2005 156 JTS veloce broke down a fortnight age, and its still in the garage!, yes a fortnight, the garage said the high pressure fuel pump had failed, so after fitting a used replacement part, it still didn't start, then the fuel regulator was to balme, and after fitting a used replacement part, it still is not delivering fuel pressure at the fuel rail, they have had the lap top on it and seemingly it is all as it should be, however i still have no car, they now tell me they think the replacement fuel punp is at fault, has anybody had similar JTS problems and can anybody give me some advice, because if i had any i would be tearing my hair out by now, many thanks Eddie.:
eddiesalfa is offline  
Sponsored Links
Status: bring back tapatalk
AO Silver Member
trashbat's Avatar
Join Date: Jun 2010
Location: United Kingdom
County: Hampshire
Posts: 2,518
If they are going off the read faults rather than doing a proper diagnosis, clogged injectors may manifest as this fault. Incorrect/no flow through injectors = incorrect pressure at pump = fault code.
trashbat is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

fuel , issues , jts

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome