Alfa Romeo 147 Battery Draining - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 01-11-12 Thread Starter
Status: -
Join Date: Jun 2012
Location: United Kingdom
County: Lincolnshire
Posts: 1
Alfa Romeo 147 Battery Draining

Hi Everyone,

Need some advise if possible. I went to start my car this morning and my battery was flat tried to jump it but no good so phoned the RAC out and they have said that my battery was completley knackered so got bought a new battery. He also said that the reason the battery is going flat is not something is slowly draining the battery. After an hour of seaching different fuses / wires we found that under the steering wheel there was ecu plug with a red connector we unplugged this and there was no drain on the battery we plug it back in and there was a slow drain again.

Has anyone else this kind of problem? Is it a an easy fix??

Look forward to hearing from anyone
GRJOHNS is offline  
Sponsored Links
Status: -
Club Member
Membro Medio
ALFAPAT's Avatar
Club Member Number: 237
Join Date: Nov 2001
Location: United Kingdom
County: Moray
Posts: 1,862
Images: 6
Try disconnecting the alternator or better still if you haven,t been anywhere ry getting your hand to the alternator and see if its warm , it could be bad diodes and the alternator is discharging while sitting.
It may so chartging while running but discharges while it sits.
ALFAPAT is offline  
Status: Alfa nut
AO Silver Member
Join Date: Dec 2011
Location: United Kingdom
County: East Sussex
Posts: 1,271
As above but also check the rear lights are not staying on= body computer burning out.
jim hazell is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

147 , alfa , battery , draining , romeo

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome