Temp gauge barely rising now Winter. - Page 2 - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
Status: TJR Valeting
AO Silver Member
Tommywho156's Avatar
Join Date: May 2012
Location: United Kingdom
County: Leicestershire
Posts: 2,267
Originally Posted by steveisfrowning View Post
DIY is a cinch - lots of advice in the link posted previously.

Ridiculous to pay 150. 2 hours for a mechanic is a joke.
I've done it plenty of times on other vehicles but thought that with it being covered on my warranty I'd let them take care of it. I think many garages see an Alfa and rub their grubby hands together and pluck a quote out of the ether and double it.
Tommywho156 is offline  
Sponsored Links
Status: Gold Member
AO Gold Member
rarebear's Avatar
Join Date: Sep 2002
Location: The Netherlands
Posts: 7,021
we all want to make some money, garages are no different.....thats why DIY is so much more rewarding
rarebear is offline  
Status: - Update
Posts: n/a
Autolusso will do it for 100 including coolant replacement. As it's got some other work to do also, I thought I'd let them deal with it.

Video of the typical symptoms: Failed Thermostat Alfa Romeo 156 2.5 V6 - YouTube
Status: - Update
Posts: n/a
Work done. Thermostat replaced at 100 from Autolusso. Problem solved. Temp gauge raises and falls properly now.
Status: diem25.org
Club Member
Membro Premio
Elvis Presley's Avatar
Club Member Number: 59
Join Date: Aug 2006
Location: In a rockin good place
County: Memphis
Posts: 72,968
Images: 5

Member car:

A galleon

nice one
Elvis Presley is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

barely , gauge , rising , temp , winter

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome