156 Smells like I've got something decomposing inside - Page 2 - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
Status: -
AO Member
Join Date: Jan 2010
Location: United Kingdom
County: Derbyshire
Posts: 53
My Spider had a dreadful smell in it, only when I used the screen jet and for a good time after. Some bleach in the water bottle (off the car of course) and hey presto ship shape and Bristol fashion!
LAVERDA1 is offline  
Sponsored Links
Status: The last of the 156 Interceptors...
AO Member
AutobotVanguard's Avatar
Join Date: Jun 2011
Location: United Kingdom
County: Cheshire
Posts: 982
Images: 348
Where does the pollen filter live? My car smells a bit musty.

AutobotVanguard is offline  
Status: -
AO Silver Member
Join Date: Apr 2008
Location: New Zealand
County: -
Posts: 2,239
On facelift 156's they are under the dash kind of in the centre and accessed from the passengers side. Next to the blower fan. They are quite well hidden (I say they because there are 2 of them) so a guide is a big help. Googling something suitable should bring one up - I found one in Japanese but the pics were what I needed.
sprint_veloce is offline  
Status: -
AO Member
Gabster's Avatar
Join Date: Nov 2012
Location: United Kingdom
County: Warwickshire
Posts: 261
Images: 46

Member car:

156 2.0TS

Smelly car

I had the same problem in my 156 and managed to trace it to the Wash System! Dead simple - just put some sterilising fluid into the tank (stuff you wash baby bottles with). Smell went in a couple of weeks and never came back. :0)
Gabster is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

156 , decomposing , inside , smells

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome