Waterpump suspect! - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 14-10-12 Thread Starter
Status: -
AO Member
Join Date: Sep 2010
Location: United Kingdom
County: Surrey
Posts: 69
Waterpump suspect!

Not driven car for a few days, this morning decided to check oil, etc. before taking it out and discovered that the coolant tank was EMPTY! Changed the rad and thermostat recently and filled with new coolant and was keeping an eye out to see if any coolant leaks/loss anywhere, all was fine. Topped up coolant to the required level (about 1 litre) and started the engine, immediately noticed water dripping from under the AC comp area, stuck my head under the engine and noticed the water appears to be coming from behind the black plastic cover to the aux/timing belts. Not a waterfall but just a drip-drip!
Question: Can I replace the water pump with just removing the aux belt without upsetting the timing, etc? Basically, easyfix is what I am looking for.
T4hir is offline  
Sponsored Links
Status: -
AO Platinum Member
David C's Avatar
Join Date: Aug 2003
Location: London, England
Posts: 28,990
Originally Posted by T4hir View Post
Question: Can I replace the water pump with just removing the aux belt without upsetting the timing, etc?
No, because the waterpump is driven by the cambelt on the TS/JTS...
David C is online now  
Status: AROC 916 Registrar
AO Gold Member
Mitch916's Avatar
Join Date: Nov 2002
Location: United Kingdom
County: Kent
Posts: 8,803
Images: 8
Water pump = cam belt kit I'm afraid
Mitch916 is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

suspect , waterpump

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome