156 Selespeed Smoking After 3500 rpm - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 1 Old 09-10-12 Thread Starter
Status: -
Join Date: Dec 2008
Location: South Africa
County: -
Posts: 8
156 Selespeed Smoking After 3500 rpm

So thats what happens - any gear, after I hit 3500 rpm its like the car sucks in, loses all its power for 2 or seconds, and behind me a massive amount of grey smoke engulfs anyone there

Please tell me this is just valve stem seals or something? Other than that theres no other issues.

Also the car continues to spew this smoke while driving, but after a minute or so the smoke drastically reduces. If the car stands for a while (few hours) the smoke dissapears - and sure enough if I go over 3500 rpm again same thing. And I noticed the tappets are also now making a noise.. Any help would be much appreciated! thanks.

Ps. The car has stood for a long time as I was out of the country and no one used it. Maybe I should drain the oil and stuff as well?
Alf156rom is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

156 , 3500 , rpm , selespeed , smoking

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome