147 as slow as 1.0 Corsa - Page 3 - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
Status: Living the Dream
AO Member
alfatan's Avatar
Join Date: Jun 2010
Location: United Kingdom
County: Newport
Posts: 738
Images: 30
Originally Posted by Alfafamily View Post
See post number 5. Your first reply.
And post no 16!! and 21 ah well at least its sorted!
alfatan is offline  
Sponsored Links
Status: I drive way too fast to worry about cholestrol.
AO Member
alfabloke's Avatar
Join Date: Jun 2006
Location: United Kingdom
County: Devon
Posts: 73
Originally Posted by Alfa156Melb View Post
Seems they can easily get confused! lol

Lucky I don't listen to doof doof dance music in the car.. the engine would cack it's self to a fast beat!
Ha ha! Maybe classical is the safest bet from that point of view.
alfabloke is offline  
Status: knob
AO Member
Dex87's Avatar
Join Date: Nov 2011
Location: United Kingdom
County: Norfolk
Posts: 279
Images: 6

Member car:

GT Clover

...I would have used this as a nice excuse to fit a full performance exhaust system...
Dex87 is offline  
Status: Silver Member
AO Silver Member
CroBaron's Avatar
Join Date: Jul 2006
Location: United Kingdom
County: Carmarthenshire
Posts: 2,230
Images: 8

Member car:

156 2.0TS

Speed bumps and driving through deep water can kill cats.
CroBaron is offline  
Status: Looking for Add ons
AO Member
Sharpshooter's Avatar
Join Date: Sep 2009
Location: United Kingdom
County: Kent
Posts: 578
Images: 5

Member car:

Alfa Romeo 147

Originally Posted by AndyMac View Post
You sure it's poorly? A 1.6 TS isn't a powerful engine, and a 147 isn't a light car! It isn't going to feel fast against similarly powered lighter cars. I have a 1.8 ford CMax with its.staggering 125 bhp output and it feels as if I could push it faster! Turn the AC on and it gets worse!

I'd suggest. Finding another similar car for sale at a dealer local to you and going for a test drive before going any further replacing bits. It may just not feel fast because it isn't!
I Strongly dissagree. My 1.6ts pulls like a train.It has 140,000mls on the clock. I have a passat turbo 150bhp, and my previous car was a 150bhp 205gti. This one pulls well, even with a full load. Not a rocket ship but deffinately not slow. 1200kg is not heavy for a car. Unless im just very lucky with mine.
Sharpshooter is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

147 , corsa , slow

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome