''warning motor system control failure'' - Alfa Romeo Forum
You are currently unregistered, register for more features.    
 
Thread Tools
  (Post Link) post #1 of 15 Old 16-09-12 Thread Starter
AO Member
 
carlberry64's Avatar
 
Join Date: Mar 2009
Location: United Kingdom
Posts: 21

Member car:

147 1.6 t spark

''warning motor system control failure''

hi
ok yesterday i was driving my Alfa 147 1.6 ts and i had only drove about 2 miles when car started to run rough like it was missing and slight loss of power then got the message ''warning motor system control failure''

after about another mile with it running rough message went off and got full power again
this has happening often now has anyone got any ideas please help

thanks carl
carlberry64 is offline  
  3 Latest Threads by carlberry64
Thread Forum Last Poster Replies Views Last Post
K-Seal Alfa 147, 156 & GT carlberry64 4 476 17-09-12 17:55
''warning motor system control failure'' Alfa 147, 156 & GT RugbyPete 14 1172 16-09-12 08:52
Sluggish at low revs Alfa 147, 156 & GT I AM A GOD 4 778 17-03-09 23:41
Sponsored Links
Advertisement
 
  (Post Link) post #2 of 15 Old 16-09-12
AO Member
 
rick_1.7_16v's Avatar
 
Join Date: Jan 2010
Location: United Kingdom
Posts: 933

Member car:

1562.4jtd

U better off get it diagnostic to check the problem without codes will be hard for any1 to help
rick_1.7_16v is offline  
  (Post Link) post #3 of 15 Old 17-09-12 Thread Starter
AO Member
 
carlberry64's Avatar
 
Join Date: Mar 2009
Location: United Kingdom
Posts: 21

Member car:

147 1.6 t spark

Quote:
Originally Posted by rick_1.7_16v View Post
U better off get it diagnostic to check the problem without codes will be hard for any1 to help
thanks for your reply, what sort of diagnostic would i need if i do it myself,
seen few on fleebay would this one do the job

http://www.ebay.co.uk/itm/2210392166...ht_1596wt_1344

carl
carlberry64 is offline  
  (Post Link) post #4 of 15 Old 18-09-12 Thread Starter
AO Member
 
carlberry64's Avatar
 
Join Date: Mar 2009
Location: United Kingdom
Posts: 21

Member car:

147 1.6 t spark

i got myself a diagnostic reader today read the code was P0115 which relates to a faulty COOLANT TEMPERATURE SENSOR just ordered new one hope it solves it.
carlberry64 is offline  
  (Post Link) post #5 of 15 Old 19-09-12
AO Member
 
Join Date: Feb 2011
Location: United Kingdom
Posts: 103

Member car:

alfa romeo 156

Hi did you buy the diagnostic reader off ebay, will it work with Alfas? I have the ''warning motor system control failure'' message to and need to get a reader, Thanks
alfaromeocarlo is offline  
  (Post Link) post #6 of 15 Old 19-09-12
AO Member
 
Alfa156Melb's Avatar
 
Join Date: Oct 2011
Location: Australia
Posts: 917
Images: 14
best to download MultiECUScan, its free if you only want to check and clear codes and read some live data.. Search for Rarebear on here, he sells the cables, or you can get from ebay.
Alfa156Melb is offline  
  (Post Link) post #7 of 15 Old 19-09-12
AO Member
 
Join Date: Nov 2011
Location: United Kingdom
Posts: 544
I get P0601 - Powertrain Internal Control Module Memory Check Sum Error
RugbyPete is offline  
  (Post Link) post #8 of 15 Old 19-09-12 Thread Starter
AO Member
 
carlberry64's Avatar
 
Join Date: Mar 2009
Location: United Kingdom
Posts: 21

Member car:

147 1.6 t spark

hi
yes i downloaded multiecuscan with the reader i got i did not need it as its got a lcd screen built in

Last edited by carlberry64; 19-09-12 at 08:08.
carlberry64 is offline  
  (Post Link) post #9 of 15 Old 19-09-12 Thread Starter
AO Member
 
carlberry64's Avatar
 
Join Date: Mar 2009
Location: United Kingdom
Posts: 21

Member car:

147 1.6 t spark

Quote:
Originally Posted by RugbyPete View Post
I get P0601 - Powertrain Internal Control Module Memory Check Sum Error
Causes

A code P0601 in most cases means the PCM has gone bad. This is possibly due to a short-circuit inside the PCM. Or, if you disconnect the wires/connector from the PCM while the battery is still connected, that may also cause this code.

Possible Solutions

With a P0601 OBD-II trouble code, the most common fix is to replace and reprogram the PCM. In a few cases the dealer may be able to reflash the PCM and get it working. But more than likely the PCM will need to be replaced and reprogrammed (we recommend you take it to a dealership for this). The good news is it *may* be covered under your emmissions warranty. So even if you're out of bumper-to-bumper warranty or powertrain warranty, check your warranty guide or dealer to see if this is covered.

Other people have reported that they cleared the code only for it to return again and again. Keep in mind that most shops can replace the PCM but not all can program it.
carlberry64 is offline  
  (Post Link) post #10 of 15 Old 19-09-12 Thread Starter
AO Member
 
carlberry64's Avatar
 
Join Date: Mar 2009
Location: United Kingdom
Posts: 21

Member car:

147 1.6 t spark

Quote:
Originally Posted by alfaromeocarlo View Post
Hi did you buy the diagnostic reader off ebay, will it work with Alfas? I have the ''warning motor system control failure'' message to and need to get a reader, Thanks
hi
yes i bought from ebay item number 221039216694 was only 12.95 plus p&p you get free disk with all fault codes,
fits all cars after 1996 i think. it has a lcd screen so you can see fault codes an then clear them.

Last edited by carlberry64; 19-09-12 at 08:11.
carlberry64 is offline  
  (Post Link) post #11 of 15 Old 19-09-12
AO Silver Member
 
brave soul's Avatar
 
Join Date: Jul 2012
Location: Ireland
Posts: 1,730
Images: 2

Member car:

147 1.6TS

Quote:
Originally Posted by carlberry64 View Post
hi
yes i bought from ebay item number 221039216694 was only 12.95 plus p&p you get free disk with all fault codes,
fits all cars after 1996 i think. it has a lcd screen so you can see fault codes an then clear them.
Nice price , thank you .
brave soul is offline  
  (Post Link) post #12 of 15 Old 19-09-12 Thread Starter
AO Member
 
carlberry64's Avatar
 
Join Date: Mar 2009
Location: United Kingdom
Posts: 21

Member car:

147 1.6 t spark

Quote:
Originally Posted by brave soul View Post
Nice price , thank you .
your welcome found fault i never new i had with it
carlberry64 is offline  
  (Post Link) post #13 of 15 Old 28-09-12
AO Member
 
Join Date: Jun 2012
Location: United Kingdom
Posts: 11

Member car:

147

Cheese

Tzsegh he jeeA
Wayne0647 is offline  
  (Post Link) post #14 of 15 Old 28-09-12
AO Silver Member
 
GeoffCapes's Avatar
 
Join Date: Jan 2005
Location: United Kingdom
Posts: 1,337
Images: 23

Member car:

GT JTDm

Sounds like a MAF failure.

Had the same thing. Bought a 14 code reader on ebay. Confirmed it was the MAF.

Trip to Euro Car parts. Job done.
GeoffCapes is offline  
  (Post Link) post #15 of 15 Old 08-10-13
AO Member
 
Join Date: Nov 2011
Location: United Kingdom
Posts: 544
replaced the maf.... still getting it. MAF was bad though, but still
RugbyPete is offline  
Reply

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

Tags
control , failure , motor , system , warning

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome