Alfa 156 Cambelt Sensor Fault - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 13-09-12 Thread Starter
Status: -
AO Member
Join Date: Apr 2012
Location: United Kingdom
County: Surrey
Posts: 37
Alfa 156 Cambelt Sensor Fault

Good evening,

EDIT: Title should read 'Camshaft Sensor Fault'

I drive a 2002 Alfa 156 1.8 TS (91000 miles) and I have had a 'Motor Control System Failure' message for the last two days - and the engine has been operating in 'limp home'. I have had the engine diagnostically test, with the following result:

P0340 Camshaft Position Sensor A Circuit (Bank 1 or single sensor)... P0340

I understand that that removal of the cambelt would be required in order to replace the sensor. The cambelt was last replaced at 69,500 miles.

The garage has 'suggested' that I also replace the cambelt, water pump and variator at the same time.

I am sure this question has been asked before, but I am interested to hear what the general consensus/recommendation on hear would be??

Many thanks

Last edited by Oxygene; 13-09-12 at 20:49.
Oxygene is offline  
Sponsored Links
Status: age is only a number ;-)
AO Gold Member
rgwm's Avatar
Join Date: Aug 2004
Posts: 9,069
Yes the cambelt sensor is behind the exhaust pulley, so needs belt off to replace. For the price of a belt, I guess replacement is sensible, unless its less than say 5K miles old. Replacing anything else largely depends on when they were last replaced, really - if its 30K since the last belt change you want to be changing all tensioners, and maybe the water pump if that wasn't changed at last belt change. Variator - depends if there is any noise from it...its not really crucial, depends how much £80 or so is to you.
rgwm is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

156 , alfa , cambelt , fault , sensor

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome