1.8 t spark engine noise - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 1 Old 08-09-12 Thread Starter
Status: -
AO Member
Join Date: Jul 2008
Posts: 12
1.8 t spark engine noise

Hello all

I've had a good read of the threads and think my engine might be pinking or maf fault or exhaust bracket or variator....

The car is a 2003 1.8 t-spart 59K cambelt changed 23,000 miles ago (4 years) I know the variator is dodgy as I've had the problem before at start up (diesel sound for 3 seconds) this is my 3rd 156! A cambelt change is written on the water bottle in black marker 10k ago but I don't have a receipt so not counting that.


I noticed with the windows down in the hot weather that there is a noise under gentle acceleration, when the revs are a little low. It's a bit of a tappety sound, similar to the variator noise at start up - can the variator cause this noise under accelartion or is it something else. The car needs a full cambelt/pump/variator change but I've been quoted 500+ so waiting for the right time financially. The sound only lasts 2 seconds and isn't too loud. Power does seem to be a little down but tickover and engine temp are faultless. In the engine bay the heat shield (big metal bit lowish down at the front) split which is a little odd.

Hope that's enough info!

PHELS99 is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

engine , maf , noise , rattle , spark , variator

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome