Engine just cut out? - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 06-09-12 Thread Starter
Status: -
AO Member
Join Date: Feb 2007
Location: United Kingdom
County: Cardiff
Posts: 683
Engine just cut out?

Any ideas guys? I've just bought a 2.0 twinspark 147 with the big ends gone. I swapped the complete engine and drove it 450 miles in one trip from Cornwall to Aldershot and it didn't miss a beat.

Today, i've just popped down the shops in it and the engine has cut out, was going up a slight hill, it felt down on power, I dropped it down a gear and it died. It said low oil pressure just as it died. I tried to re-start it and it started but wasn't idling nice and when I tried to move off it died again and the low oil pressure light came on again. It sounded ok though, no knocking or anything.

I've abandoned it at the side of the road for now. There are no engine management lights when I restarted it.

I assuming the low oil pressure is a red herring as it happens as it's just about to cut out?

I had a look under it expecting to see an oil slick or something but it all looks fine and there is oil in the sump.

Any ideas guys?

Last edited by Escy; 06-09-12 at 15:39.
Escy is offline  
Sponsored Links
Status: - Update
Posts: n/a
Low oil pressure is a normal warning when a car looses power while running... It will say that because the engine isn't creating enough oil pressure when it is stalling slowly...

It sounds like more of a simple electrical connection issue to me.... Logic suggests that you have had the battery off during the engine swap, so that is where I would start.
Check your battery connections first, pay attention to the positive terminal making sure that both metal rings are on the battery post firmly before nipping up the securing nut.
Check the battery earth points to the body by following the negative cable to it's termination points aren't broken or loose.
Check the MAF connection, unplug it if you need too, it may run roughly and idle lumpy but see if it drives ok without dying.

How much fuel is in the car?
(Post Link) post #3 of 3 Old 06-09-12 Thread Starter
Status: -
AO Member
Join Date: Feb 2007
Location: United Kingdom
County: Cardiff
Posts: 683
Originally Posted by Grahameo View Post
How much fuel is in the car?
I can't believe it you were right. The gauge was showing a bit of fuel in it, it must over read slightly. I can believe it. I've run out of fuel in the past, (not in an Alfa) and it's usually a bit flat and coughs and sputters. This died pretty quckly. Was about 5 seconds between power drop and the engine cutting out.

I feel bad now, I cursed it under my breath.
Escy is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

cut , engine

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome