gt 2.0.jts starting problems update - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 1 Old 02-09-12 Thread Starter
Status: -
AO Member
Join Date: May 2012
Location: United Kingdom
County: North Yorkshire
Posts: 18
gt 2.0.jts starting problems update

hello all just thought i'd let you all know pick my gt up tomorrow, been in garage 3 weeks, and off the road for 9 weeks with starting problems. Turned out to be a faulty coil which caused a wire to burn out and affect the adjoining fuel pump related wire which caused low fuel pressure resulting in a p0191 fault code which subsequently had absolutely nothing to do with the actual fault which had stopped the car in the first place, cars eh dont you just love em!!!!,i'll let you guys know hows shes running and what it costs for a non alfa specialist to fault find on an alfa as soon as i can, although no doubt now hes calling himself an alfa specialist
Andy coates is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

20jts , problems , starting , update

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome