2.4 20v engine cut out flashing engine management light and glow plug light - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 1 Old 20-08-12 Thread Starter
Status: -
AO Member
fanalonehf's Avatar
Join Date: Jun 2008
Location: United Kingdom
County: Hampshire
Posts: 41

Member car:

2.4 jtd saloon

2.4 20v engine cut out flashing engine management light and glow plug light

Hopefully someone can advise >

Driving home tonight engine management light came on and glow plug light light started flashing together the VDC and abs failure lights came warning message and engine stopped!

Coasted into a garage and car refused to start !

night before light came on and reset on way to friends to clear codes two codes cleared baromatic sensor and over boost I think !

all good on way to work engine light comes on again goes into limp mode ign on off normal power but light on.
the engine cranks over fine but flashing engine and glow plug light flash rapidly ? it has had new plugs.

the lights go off and you can hear the relays behind batery clicking and the egr and the boost air pump thing below fuel filter on back of engine. then vdc and abs lights warning flashes up the engine light and glow plug light go out.

plugged in sun diagnostic and it wont connect to identify ecu so cant see whats wrong ?

any ideas?

regards Andy
fanalonehf is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

20v , cut , engine , flashing , glow , light , management , plug

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome