MAF / Clutch problems - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 4 Old 11-05-05 Thread Starter
Status: -
AO Member
lizardchops's Avatar
Join Date: Feb 2004
Location: Fareham
Posts: 28
MAF / Clutch problems

hmmm....My second Alfa and already had Airbag ECU replaced and all 5 glow plugs on 2.4JTD Sportwagon 2000.

Took it to Monza Sports (Brilliant people) and they told me that clutch riding high and slipping. Also Turbo seems sluggish until it hits 3000rpm then it flies and then holds back for a while and then gets going again!

Clutch seems to slip slightly, mainly in 1st and Reverse and they suggested Air Flow Meter knackered. I had it replaced in my old 2.0TS and did not seem to make a lot of difference.

I am not sure how it is supposed to feel (Clutch) in this car as I have nothing to compare it to. All I know is that it does not start engaging until I am almost off the clutch. If I floor it, the rev counter does not go mad either. If I travel along at about 30 in third or fourth gear the car judders and jerks horribly. Is this normal? It does not happen all the time though.

Disappointed with performance though until it gets above 3K revs as it feels so heavy and hardly moves. Then you get a kick and it goes.

Any suggestions or confirmations that it could be Air Flow Meter?

Many thanks
lizardchops is offline  
Sponsored Links
Status: - Update
Posts: n/a
Re: MAF / Clutch problems

It could be....I've had three fitted to try and cure the hesitation at 2800-3200 and not fixed it yet. Dealer has no idea either

I found I had the learn how to drive the JTD to get the best out of it and it needs a healthy dose of revs below about 2000revs to get it going.

The performance on my car did improve after the first AFM so this could be part of your problem...

The lumpiness when travelling at 30mph in 4th is the same as mine, they don't really like the low revs tootling, I use third when the engine labours at these speeds.

Status: -
AO Member
moondevil's Avatar
Join Date: Jul 2006
Location: Essex
Posts: 22

Member car:

1999 156 2.4 JTD

Re: MAF / Clutch problems

Sorry to resurrect an old thread, but thanks! I was sure I had a problem with my JTD, but the symptoms you have described are spot on. I'm used to PD (VW) diesels which whilst flat, are not completely gutless below 2000rpm like the Alfa. I'll be dosing the right foot a little more and keeping my eye on the rpm.

Thanks again.

(Just goes to show that search and ye shall find )
moondevil is offline  
Status: -
AO Member
Join Date: Jun 2006
Location: Berkshire
Posts: 21
Re: MAF / Clutch problems

Am experiencing very similar problems at the moment. The car is actually in the garage as I type.

But I have already had the air flow meter chanaged becauce of a power problem so the garage is looking at the turbo as well.

The clutch - well I am wating for a phone call.............

(I enjoy(?) reading all the enteries but boy are some of them scary. I have had my sportwagon for about 8 weeks and am still alittle nervous about the whole Alfa thing - But I have to admit that she is a pleasure to drive.... and does she go well
robsportwagon is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

clutch , maf , problems

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome