Gt Jtdm climate control - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 1 Old 10-08-12 Thread Starter
Status: loving my ALFA
AO Member
Join Date: Nov 2011
Location: United Kingdom
County: Tyne and Wear
Posts: 860

Member car:

alfa gt jtdm

Gt Jtdm climate control

hi had my climate checked in March no problems found .Then couple weeks ago after having a double din fitted it stopped working ,if i switched it on and off a couple times it felt like it was working .I did the reset thing by taking the neg off the battery and i thought it started working again, it has never been 100% since i got the car .Took it to the local Auto Elec and Air Con man he checked it over and said when you turn it on no power is getting to the compressor .So booked it back in for 2 days and he found that there was a break in the feed from the fuse box to the compressor, he has rewired it ,checked the whole system and it now works perfectly .Now another really strange thing the headlight adjusters have never worked till now very odd I know, its an ALFA i hear you all say lol .Now the killer the bill it was 252. I am in the Dog house big style with my Mrs as I have already spent a fair bit on my Alfa Do like it a lot though
300stu is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

climate , control , jtdm

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome