Gt Jtdm climate control not working - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 19-07-12 Thread Starter
Status: loving my ALFA
AO Member
Join Date: Nov 2011
Location: United Kingdom
County: Tyne and Wear
Posts: 860

Member car:

alfa gt jtdm

Help Gt Jtdm climate control not working

hi all had to change battery got a right bargin from europarts Exide 4 year warrenty 640 CCA
for 70 chuffed i am .Replaced said battery and climates not working , all lights and fans working, has the system serviced 2 months ago ,think the compressor not coming on .Any ideas people
300stu is offline  
Sponsored Links
Status: Thinking about giulia veloce
Club Member
Membro Premio
jwq's Avatar
Club Member Number: 857
Join Date: Jan 2005
Location: The Netherlands
County: Zuid Holland
Posts: 4,103
Images: 16
Most common cause for the airco compressor not working is either
a) Airco system needs to be filled
b) airco system was overfilled
jwq is offline  
Status: -
AO Member
DavrosAlfa's Avatar
Join Date: May 2012
Location: United Kingdom
County: West Sussex
Posts: 123
Did you wait 5 mins after replacing the battery to let the aircon reset itself?

Im not sure if this will help but try disconnecting the battery then reconnecting. Then wait until all the stranged noises stop and try it again
DavrosAlfa is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

climate , control , jtdm , working

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome