Help Gt Jtdm failed to start - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 1 Old 13-07-12 Thread Starter
Status: loving my ALFA
AO Member
Join Date: Nov 2011
Location: United Kingdom
County: Tyne and Wear
Posts: 860

Member car:

alfa gt jtdm

Help Help Gt Jtdm failed to start

Cars been in paint shop last couple days, got her back last night, went out came home put her in garage .Then this morning went to start her ign on turned key nothing dash lights went out still nothing, no attempt, no starter noise just silence .As I had to go to work borrowed wifes and left it in garage .What u think people flat battery, thing is central locking and alarm still working .I know it being a diesel it needs loads power from battery to turn starter .tried getting in touch with paint shop no luck so i cant confirm they disconnected the battery while working on it .Any thought would be appreciated cheers .
300stu is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

failed , jtdm , start

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome