156 2.0 JTS -04 Motor control failure - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 5 Old 09-07-12 Thread Starter
Status: -
Join Date: Jul 2012
Location: Sweden
County: Örebro
Posts: 3
156 2.0 JTS -04 Motor control failure

I purchased this car a few days ago, the seller said it worked like a clock.

After driving a few miles a message appeared, "Motor control Failure, go to dealer" or something. I went to a shop and they read with the computer these codes:

P0300 - Ignition Failures (generic)
P0303 - Cyl. 3 ignition failures
P1175 - Mixture 2 strength (multiplicative)
P0420 - Catalyser 1
P1176 - Mixture 2 strenght (additive)

I am by no means any car expert. The mechanic said it was running badly on low speed, and that someone had put tape on the tube for the air inlet.

The mechanic has so much to do, so he can't check the car properly until two weeks.

Does anyone have any idea if this could be expensive and what could be wrong with car.
Perrran is offline  
Sponsored Links
Status: got 147 for the wife
AO Member
Join Date: May 2008
Posts: 229
Images: 13

Member car:

ALFA 159 1.9 JTS

mmmm, not too sure about this mate, i have the very same car,qnd its all good ,but had one brand new that the motor control system failure came up 6 mnths old, it was the actuater throttle pedal that was the culprit, sorry thats all i know.
mr italy is offline  
Status: I am a KEITH
AO Member
mini jts's Avatar
Join Date: Aug 2009
Location: United Kingdom
County: Hampshire
Posts: 230

Member car:

156 jts

First thing to do buy a new intake or do a better repair so no air leaks for now.
I would then check coil pack on 3 and see if there any signs of damage to the coil pack or oil around spark plug if not check spark plug to see if its normal colour or oily black . good luck..........
mini jts is offline  
Status: -
AO Member
Join Date: Feb 2011
Location: United Kingdom
County: West Midlands
Posts: 76
Images: 6
This message can crop up for all sorts of reasons and not all are serious.......JTS's are a little sensitive to low fuel level in the fuel tank for example when taking corners quickly.....Does the car drive OK or does it feel low on power or in Limp Home Mode???. If it feels OK there may be nothing wrong, may have just reacted to a spurious sensor signal....not unknown. The message "times out" after 8 restarts of the engine and if the message does then disappear I would suggest there is not that much wrong. However I would certainly agree with the previous comment about replacing the air inlet tract as this could / would cause issues etc..
mollyjo is offline  
(Post Link) post #5 of 5 Old 11-07-12 Thread Starter
Status: -
Join Date: Jul 2012
Location: Sweden
County: Örebro
Posts: 3
Thanks all Of you.

The mechanic **** down the warning notification and said that we should return when it lighted up again, it happened after 100m. Unfortunately everyone has vacation here in Sweden so I can't check the car properly until next week. So my car vacation just went out the window.

Is it difficult to do these things by myself or is it mechanic men stuff to do?
Perrran is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

156 , control , failure , jts , motor

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome