Alfa 156 head unit issue- random speakers cutting out - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 4 Old 08-07-12 Thread Starter
Status: -
AO Member
Join Date: Mar 2011
Location: United Kingdom
County: North Yorkshire
Posts: 70
Images: 6
Alfa 156 head unit issue- random speakers cutting out

Hey guys,

My Alfa has started this unusual trait where when the stereo is on, it will suddenly play out of one speaker and the others will quietly produce white noise. However, if I turn it off and back on again, it is fine again for a few minutes.

I have checked the connections and they are definitely solid. Taking them out and back in etc. But no change. I am not sire if this is unusual, but the casing of the head unit is burning hot when I remove it shortly after playing. Not sure if it overheating or damaged. The speakers do sometimes flicker back or swap sides. I have no idea what it is but it is very annoying!

Any help is greatly appreciated
SCHNICK_18 is offline  
Sponsored Links
Status: Loving the Wizard exhaust!
AO Member
20v_gaz's Avatar
Join Date: Jan 2013
Location: United Kingdom
County: Warwickshire
Posts: 72
Images: 12
Did you ever have any luck with sorting this. I have exactly the same issue :-(
20v_gaz is offline  
AO Member
BIGp's Avatar
Join Date: Sep 2007
Location: United Kingdom
County: Cambridgeshire
Posts: 109
Images: 4

Member car:

156 v6

personally i would be taking out that head unit before it sets fire to the car!!!sounds like you have a earthing problem??
BIGp is offline  
Status: supercharger! ...hmmm
AO Member
alfabum's Avatar
Join Date: May 2012
Location: United Kingdom
County: Tyne and Wear
Posts: 137
Images: 6
Had a problem with speakers cutting out, it was the wiring connector in the door hinge - the round one with corrugated rubber over it - unplugged it and plugged it a few times and hasn't happened since.
alfabum is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

156 , alfa , cutting , head , issue , random , speakers , unit

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome