Airbag & ABS warning lights - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 06-07-12 Thread Starter
Status: -
AO Member
Join Date: Jul 2012
Location: United Kingdom
County: Lincolnshire
Posts: 41

Member car:

147 TS 1.6 Lusso

Help Airbag & ABS warning lights

Hi to all, Have just joined here and obviously I need some help please.
From what I've read I think that I am in the right place.

I picked up 156 1.8 TS(2000 Reg) to use as a donor car after t/belt went on my 02 version.
Am driving the donor for a while and have discovered a few probs.
The airbag and abs warning lights come on but only when the headlights are on.They were coming on when braking but changing a rear stop and tail bulb and scraping some corrosion of the bulb holder seemed to fix that.

It also seems to run very lumpy and lacks the power of my other one.Now, before I order plugs,leads,maf or lambda sensors.Is there a quick/cheap way to diagnose at all? Am certainly no mechanic but I do have a go.
Would be really grateful for any advice on these issues.
Regardless, I love these car and can't believe I waited until I am in my 40's to buy one.

Thanks for looking.

bbz68 is offline  
Sponsored Links
Status: Gold Member
AO Gold Member
rarebear's Avatar
Join Date: Sep 2002
Location: The Netherlands
Posts: 7,021
You need diag software, alfadiag or fiatecuscan and a cable
rarebear is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

abs , airbag , lights , warning

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome