Bose or not? - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 06-07-12 Thread Starter
Status: -
Join Date: Jun 2012
Location: New Zealand
County: Auckland
Posts: 3

Member car:

Alfa 147

Bose or not?

Hi all i just got my first 2005 Alfa 147 and wanting to know if mine has the Bose speakers as it doesn't have the Bose logo like some of other 147 i have seen. Also how would i know what trim i have got. It has black leather seats and dual climate control. thanksin advance

Sibu999 is offline  
Sponsored Links
Status: Freezing!
AO Silver Member
Rockhopper's Avatar
Join Date: Mar 2007
Location: United Kingdom
County: Nottinghamshire
Posts: 4,862
If it doesn't have Bose logo's then it doesn't have Bose! (it'll also have a huge sub woofer in the boot)

Yours sounds like a Lusso.

Last edited by Rockhopper; 06-07-12 at 03:30.
Rockhopper is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT


Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome