Selespeed actuator leak & 4th gear crunch - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 1 Old 03-07-12 Thread Starter
Status: -
Join Date: Sep 2007
Posts: 4

Member car:


Selespeed actuator leak & 4th gear crunch

A bit of history:
I have had my 147 for 5 years and have done 45k fairly trouble free motoring. Recently the car suddenly had selespeed failure come up. I was able to diagnose the problem as a sensor on the actuator (I already had alfadiag from a previous episode which turned out OK) so I bought a new sensor off ebay and fitted - fixed. I did notice a bit a oil on the actuator when I was working on it but did not think too much of it.

Couple of weeks later noticed that I would get a crunch when going from 3rd to 4th. Looked at the actuator again and again noticed this leak which is definitely coming from the actuator opposite end to the accumulator (in the same area as the previously failed sensor).

I have read other threads and most talk about changing the gearbox oil to fix crunching gear changes. However one thing which is making me think its the leaking actuator is that the first couple of 4th gear selects of the day are OK which does not seem to go with old gearbox oil. So my question is how likely is a leaky actuator to cause a crunching gear shift?

Caz is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

4th , actuator , crunch , gear , leak , selespeed

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome