Problem with centre check console - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 1 Old 30-06-12 Thread Starter
Status: Nearly there !
AO Member
Join Date: Jun 2012
Location: United Kingdom
County: Lincolnshire
Posts: 210
Problem with centre check console

I hope someone can shed some light on this as my alfa is due its MOT soon ... Its a 1.8ts .. I today after purchasing it and driving a long way home that when I came to restart the car the centre check light display is not working properly and the only lights that come on are the key symbol for the immobilizer and also the door/boot/bonnet symbols. The rest of the lights in there do not even light up. I have checked all the fuses and everyone of them is ok ?. Also my engine management light is on but as its running fine and revving all the way up I not too concerned about that . It's the other check lights I am more interested in if I am missing something as to why they are not working ? Thanks
Mike Wressell is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

centre , check , console , problem

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome