New clutch master cylinder issues - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 1 Old 26-06-12 Thread Starter
Status: -
AO Member
Join Date: Dec 2011
Location: United Kingdom
County: East Riding of Yorkshire
Posts: 115

Member car:

alfa romeo gt

New clutch master cylinder issues

Had this swapped out today on my GT jtd by my usual garage, but it now has at 3/4 free travel before anything happens, I have checked this by having the pedal pressed whilst looking at the actuator arm on the g box and it doesn't move until the last inch or so of the pedal press.

Is this a case that it hasn't been bled properly?, if I pump it it is slightly better but why is this?

It has had new slave and everything has been fine but the master slave's notchiness and creak in the last part of upward travel became too much to bare, is this an issue with what the garage have done?


jon kirby is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

clutch , cylinder , issues , master

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome