Radio Antenna Amplifier - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 1 Old 02-06-12 Thread Starter
Status: -
Join Date: Feb 2012
Location: United Kingdom
County: North Yorkshire
Posts: 1
Not Happy Radio Antenna Amplifier

I currently drive a 147 JTD Q2 Ducatti Cors and have recently lost any reasonable FM or AM radio reception unless I am in sight of a transmission mast. The headset checks out alright and so does the antenna lead to the headset. I'm unsure whether the roof antenna contains its own amplifier or if there is an in-line amplifier on the antenna cable. Anyone have any ideas about this problem please? If there is an amplifier does anyone know where its located? My manual shows it to be in N/S boot pillar but I've checked and it isn't there. Don't want to strip all the trim off looking for it. Hope someone can help.

Last edited by Geoff.Bee; 02-06-12 at 19:10.
Geoff.Bee is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

amplifier , antenna , radio

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome