Actuator and Pump required for 156 - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 28-05-12 Thread Starter
Status: -
Join Date: May 2012
Location: United Arab Emirates
County: Dubayy
Posts: 1
Actuator and Pump required for 156

I know the problem is common.
I have an ALfa Romeo 156, Selespeed 2004 and have a need for an actuator and pump. In case anyone knows the best way to go about finding one please let me know.
Email :
Thank you
xristaras is offline  
Sponsored Links
Status: RadicaL
AO Member
pull's Avatar
Join Date: Jun 2009
Location: United Kingdom
County: Kent
Posts: 278
PM rgwm on here - he is an alfa breaker and has many a part (too many I expect if you asked his wife )!
pull is offline  
Status: -
AO Silver Member
Join Date: Aug 2007
Location: United Kingdom
County: Staffordshire
Posts: 2,463
yep got some give me a call.
italiaautoparts is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

156 , actuator , pump , required

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome