Steinbauer PBox Installation - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 22-05-12 Thread Starter
Status: -
AO Member
Join Date: Oct 2011
Location: I would rather not say
County: -
Posts: 117

Member car:


Steinbauer PBox Installation

Recently got myself a pbox for my 156 2.4jtd and have already fitted it, but have not really noticed any difference.

I connected battery positive and negative, there was no white wire for throttle reference, not even at the plug end of the loom which goes into the pbox, just a grey one which I believe is for switching the box off, if its connected to ground, so I've left that taped up.

It had all its dipswitches set to on, including dip 3, which isn't documented anywhere?
So I set it to dip 1+2 on, 3+4 off, which is 130%

Anyways, theres no real difference that I can feel, and from reading past comments about fitting them, it should be quite apparent.

Any ideas guys?
MoleUK is offline  
Sponsored Links
Status: Persistant
AO Member
Join Date: Apr 2011
Location: United Kingdom
County: Worcestershire
Posts: 96

Member car:

Alfa 147 2.0

How much did you pay for the box?
Graphic is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

installation , pbox , steinbauer

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome