Error Codes Found - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 10-05-12 Thread Starter
Status: -
Join Date: May 2012
Location: United Kingdom
County: Oxfordshire
Posts: 5

Member car:

147 t spark

Error Codes Found

Hi All,

Wondering if anyone can help... I recently became a Alfa 147 owner as many years of admiring from afar... Only problem is that it is second hand and showed a fault light. A friend hooked it up to his 'thingy' and found these fault codes;

U1600 - i believe this to be immoboliser fault - possibly as battery pack missing on Key Fob????
P0571 - Cruise Control/Brake switch fault
P1688 - Have read a couple of different versions of what this could be so far
P1689 - Have read a couple of different versions of what this could be so far

can anyone tell me if these are easy faults to fix ... or... have a been sold a duff car...
coxy030 is offline  
Sponsored Links
Status: v6 rules
AO Silver Member
gtvtommo's Avatar
Join Date: Apr 2011
Location: United Kingdom
County: West Midlands
Posts: 1,084

Member car:

916 v6 lusso

the immobiliser has nothing to do with your battery in fob.......that battery powers central locking/alarm. Its possible but unlikely that the transponder (needs no fob power from battery) has been lost from the key. otherwise it could be the imobiliser itself.

fault P1688 refers to the oilpump stepper motor I believe and 89 an oil control solonoid

You really need to overcome the immobiliser problem 1st. then say the car is duff at this stage would be premature in my view.
gtvtommo is offline  
Status: Long, Low and Slow ..
AO Member
Shadeyman's Avatar
Join Date: Nov 2010
Location: United Kingdom
County: West Midlands
Posts: 492
Images: 9
Ask you friend to clear the fault codes and see which ones return.

Some may just be left behind from earlier problems that have now been fixed.

Any that return will be the ones you need to cure.
Shadeyman is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

codes , error , found

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome